1С префикс в документах

1С:Бухгалтерия и 1С:Управление торговлей 11 по-разному формируют печатные формы счетов-фактур: Бухгалтерия оставляет только номер, а Управление торговлей оставляет еще и префикс документа. При совместном использовании этих конфигураций такая ситуация часто вызывает недовольство бухгалтеров, которым нужно, чтобы счета-фактуры, распечатанные из разных программ, выглядели одинаково.

Итак, задача — убрать префиксы из номера печатной формы счетов-фактур в 1С:Управление торговлей 11.

В 1С:Управление торговлей нет пользовательских настроек, позволяющих управлять выводом префикса на печать, поэтому придется немного скорректировать конфигурацию.

За формирование номеров в печатных формах отвечает функция НомерНаПечать общего модуля ПрефиксацияОбъектовКлиентСервер:

Функция НомерНаПечать(Знач НомерОбъекта, УдалитьПрефиксИнформационнойБазы = Ложь, УдалитьПользовательскийПрефикс = Ложь) Экспорт
//Содержимое функции в данном случае нам не важно
КонецФункции

Функция имеет 3 входящих параметра:

  1. НомерОбъекта — номер документа, который нужно преобразовать.
  2. УдалитьПрефиксИнформационнойБазы — булево, если Истина, удаляет префиксы базы.
  3. УдалитьПользовательскийПрефикс — булево, если Истина, удаляет пользовательские префиксы.

Нас будет интересовать второй параметр — УдалитьПрефиксИнформационнойБазы (хотя, не исключаю, что в некоторых случая понадобится и третий, если вы сталкивались с этим, пожалуйста, напишите в комментариях). Нам нужно при вызове этой функции передать во второй параметр значение Истина.

Для формирования печатной формы счета-фактуры используется обработка ПечатьОбщихФорм. В модуле менеджера этой обработки есть функция НомерСчетаФактурыНаПечать:

Функция НомерСчетаФактурыНаПечать(Номер, ИндексПодразделения, УдалитьПользовательскийПрефикс = Ложь)
НомерНаПечать = «»;
Если Номер <> Неопределено Тогда
НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Номер, Ложь, УдалитьПользовательскийПрефикс); ПозицияРазделителя = СтрНайти(НомерНаПечать, «-«);
Префикс = Лев(НомерНаПечать, ПозицияРазделителя);
НомерБезПрефикса = Сред(НомерНаПечать, ПозицияРазделителя + 1);
Если Лев(НомерБезПрефикса, 1) = «И» Тогда
НомерНаПечать = Префикс + Сред(НомерБезПрефикса, 2);
КонецЕсли;
Если ЗначениеЗаполнено(ИндексПодразделения) Тогда
НомерНаПечать = НомерНаПечать + «/» + ИндексПодразделения;
КонецЕсли;
КонецЕсли;
Возврат НомерНаПечать;
КонецФункции

В ней нас интересует строка

НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Номер, Ложь, УдалитьПользовательскийПрефикс);

Она отвечает за формирование номера и вызывает функцию, описанную выше. Второй параметр этой функции нужно заменить на Истина.

Окончательный вид функции:

Функция НомерСчетаФактурыНаПечать(Номер, ИндексПодразделения, УдалитьПользовательскийПрефикс = Ложь)
НомерНаПечать = «»;
Если Номер <> Неопределено Тогда
НомерНаПечать = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(Номер, Истина, УдалитьПользовательскийПрефикс); ПозицияРазделителя = СтрНайти(НомерНаПечать, «-«);
Префикс = Лев(НомерНаПечать, ПозицияРазделителя);

НомерБезПрефикса = Сред(НомерНаПечать, ПозицияРазделителя + 1);
Если Лев(НомерБезПрефикса, 1) = «И» Тогда
НомерНаПечать = Префикс + Сред(НомерБезПрефикса, 2);
КонецЕсли;
Если ЗначениеЗаполнено(ИндексПодразделения) Тогда
НомерНаПечать = НомерНаПечать + «/» + ИндексПодразделения;
КонецЕсли;
КонецЕсли;
Возврат НомерНаПечать;
КонецФункции

Для пользователей и администраторов программ 1С Если у Вас возникнут вопросы по теме статьи, или необходима помощь, позвоните нам по телефону: (495) 221-09-80, или напишите на e-mail:

Префикс устанавливается перед номером документа. Префикс полезен в тех случаях, когда в информационной базе ведется многофирменный учет. Он позволяет нумеровать документы по каждой организации в отдельности.

Настройка префиксов для документов

Префикс для документов автоматически присваивается документам, если он задан в карточке элемента справочника «Организации».

Если изменить префикс, то нумерация документов начнется сначала.

Редактирование номеров документов возможно через меню «действие», команда «редактировать номер»

Важно! Необходимо помнить, что ручное редактирование документов может привести к нарушению автоматической нумерации в системе.

Настройка префиксов для справочников.

Редактирование номеров элементов справочников происходит через меню «действие», команда «редактировать код»

Если при редактировании кода элемента справочника добавим префикс А и присвоим номер 00000001, то следующий элемент будет записан под кодом А00000002.

1. Что такое префикс базы 1С?

2. Префикс базы для обмена с сайтом.

3. Префикс информационной базы.

Что такое префикс базы 1С?

Что такое префикс базы 1С? Этот вопрос можно часто услышать из уст клиента, который обратился к Вам с проблемой сбившейся нумерации документов.

В системе «1С:Предприятие 8» (конфигурациях), которые разработаны на основе Библиотеки Стандартных Подсистем (БСП), реализовано автоматическое формирование номеров документов и других основных объектов конфигурации, с назначением префиксов базы 1С, в которых хранится уникальный идентификатор организации, информационной базы и другой дополнительной информации.

Начиная с версии 2.2 в БСП реализован интересный механизм нумерации объектов системы. Для более ранних версий БСП, а также для конфигураций без БСП используется другой принцип нумерации и префиксации объектов. Давайте рассмотрим принципы нумерации на примере 1С:УНФ (Управление нашей фирмой 8). Примерный вид номера объекта, в данной конфигурации, будет такой:
00ФР-000002

· 00 – Префикс для обмена с сайтом.

· ФР– Префикс информационной базы.

· 123 – Порядковый номер документа.

Префикс базы для обмена с сайтом.

Давайте разберем каждый префикс базы 1С по отдельности. И начнем мы с префикса для обмена с сайтом. Данный префикс базы устанавливается в константе «Префикс для обмена с сайтом». Для этого необходимо зайти во «Все функции» и выбрать раздел «Константы». После этого находим необходимую нам константу.

В зависимости от того, какой идентификатор установлен у Вас в этой константе, такой префикс базы и будет добавляться при нумерации объектов. В данном случае в этой константе у нас никакое значение не установлено. Потому вместо уникального идентификатора префикса базы 1С выводятся «00». Так происходит со всеми префиксами в системе.

Префикс информационной базы.

Следующий префикс базы у нас – это префикс информационной базы или префикс организации, как кому будет удобнее его использовать. В большинстве случаев, когда этот префикс используется как идентификатор организации, в основном в нем отображают первые буквы из наименования организации. Для того чтобы установить значения этого префикса базы, необходимо снова заходить во «Все функции», раздел «Константы». Но на этот раз необходимо искать другую константу, а именно: «Префикс информационной базы». Если идентификатор не установлен, то снова вместо необходимых символов будут выводиться нули «00».

После настройки всех идентификаторов для нумерации, номера документов и других объектов конфигурации будут выглядеть примерно так, как на рисунке. Ничего сложного в настройке префиксации нет, главное знать, какая нумерация у Вас должна получиться в итоге.

Специалист компании ООО «Кодерлайн»

Олег Мороз.

Если мы посмотрим на номер какого-нибудь документа в системе (например, реализации), то увидим примерно такую картину:

Длина номера составляет 11 символов. При этом первые 5 символов зарезервированы системой, поэтому мы можем оперировать только шестью знаками (и будем надеяться, что число документов одного вида за один год не превысит один миллион).

На что же система резервирует эти 5 символов:

  • первые 2 — это префикс организации (в одной базе могут быть заведены документы по нескольким организациям и чтобы их удобно было отличать друг от друга, сделали такую возможность);
  • вторая пара символов — это префикс узла обмена (в том случае, если используется обмен с другими конфигурациями, и многие документы создаются сразу в нескольких системах, то по данной паре символов в номере документа можно однозначно определить, в какой системе этот документ был создан).
  • Знак «-» в номере нужен для того, чтобы отделить значающие символы от служебных. В печатные формы попадает та часть номера, которая расположена справа от дефиса.

Префикс организации устанавливается в карточке организации:

Префикс узла обмена устанавливается на вкладке Администрирование, Настройки синхронизации данных

Если обмен отключен, то вторая пара символов в номерах документов — «00», если префикс организации не задан, то первая пара символов в номере — «00».

Таким образом, даже если мы не используем обмен с другими конфигурациями и создаем документы только по одной организации, задействовать все символы в номере мы не можем.

В случае, если количество документов одного вида за один год в вашей базе приближается к одному миллиону, стоит привлечь опытного программиста. Альтернатив типовой функционал пока не предлагает.