Ошибка при вызове метода контекста

Ошибка при вызове метода контекста (Записать)

Я
mr_smit Подскажите пожалуйста:
обработка ругается на:
Ошибка при вызове метода контекста (Записать) НовЭлемДСпХ.Записать();по причине:
Значение поля "Владелец" не заполнено или заполнено неверно
Попытка записать в справочник значение, у справочника есть владелец, поэтому наверное и ругается, а что необходимо сделать, чтобы правильно отработало?
 
     Timon1405

Капитан очевиднотсь в растерянности

   бомболюк

7ка?

   AlexToo

(0) у тебя тип Владельца совпадает с типом того значения которое ты ему присваиваешь?

   dezss Перед записать. НовЭлемДСпХ.Владелец = НужныйВладелец;    mr_smit Владелец у него ПланыВидовХарактеристик.ХарактеристикиОС а что дальше выбрать извините, пробел    mr_smit

8ка

   h-sp

(5) ну значеине типа ПланВидовХарактеристикСсылка.ХарактеристикиОС

   mr_smit НовЭлемДСпХ = Справочники.ДополнительныеХарактеристикиОС.СоздатьЭлемент();          НовЭлемДСпХ.Владелец = ПланыВидовХарактеристик.ХарактеристикиОС….;          НовЭлемДСпХ.Код = тУникИндификатор;          НовЭлемДСпХ.Наименование = тЗначениеХарактеристики;          НовЭлемДСпХ.Записать(); там только методы. Нужно какой то метод выбрать?    Timon1405

(8) нужно выбрать или предопределенный элемент этого ПВХ или написать там НайтиПоКоду(…)

   mr_smit вот я ему так сделал а он всёравно не хочет его воспринимать, что не так пишу?
НовЭлемДСпХ = Справочники.ДополнительныеХарактеристикиОС.СоздатьЭлемент();          НовЭлемДСпХ.Код = тУникИндификатор;          НовЭлемДСпХ.Наименование = тЗначениеХарактеристики;          НовЭлемДСпХ.Владелец = ПланыВидовХарактеристик.ХарактеристикиОС.НайтиПоКоду("Код");          НовЭлемДСпХ.Записать(); 
     mr_smit

предопределённый не могу выбрать, так как и в пвх идёт добавление элементов. в пвх добавляется, а в справочник нет ругается на владельца

   h-sp

(11) а в пвх как добавляется?

   mr_smit НовЭлемПВХ = ПланыВидовХарактеристик.ХарактеристикиОС.СоздатьЭлемент();          НовЭлемПВХ.Код =  тУникИндификатор;          НовЭлемПВХ.Наименование = тВидХарактеристики;          НовЭлемПВХ.ТипЗначения = Справочники.ДополнительныеХарактеристикиОС;          НовЭлемПВХ.Записать();                                 НовЭлемДСпХ = Справочники.ДополнительныеХарактеристикиОС.СоздатьЭлемент();          НовЭлемДСпХ.Код = тУникИндификатор;          НовЭлемДСпХ.Наименование = тЗначениеХарактеристики;          НовЭлемДСпХ.Владелец = ПланыВидовХарактеристик.ХарактеристикиОС.НайтиПоКоду("Код");          НовЭлемДСпХ.Записать();    mr_smit

а параллельно вопрос, прид добавлении код в пвх стал писать разрядность .на сплошным рядом пишет цифры, этого как-то можно избежать? Через Формат?

   mr_smit

а параллельно вопрос, при добавлении кода в пвх стал писать цифры с разрядностью,а не сплошным рядом пишет цифры, этого как-то можно избежать? Через Формат?

   Timon1405 у вас каша в голове.
во первых, почему тУникИндификатор-это код и в пвх и в справочнике??//НовЭлемДСпХ.Владелец = ПланыВидовХарактеристик.ХарактеристикиОС.НайтиПоКоду("Код"); НовЭлемДСпХ.Владелец = НовЭлемПВХ.Ссылка; вам нужно просто подставить туда ссылку на пвх    h-sp (13) наверно так
         НовЭлемДСпХ.Владелец = НовЭлемПВХ.ссылка;    mr_smit

Ссори за предыдущее сообщение, русский как не родной получился

   h-sp

(18) ну это изначально было понятно, мистер смит ведь англичанин.

   mr_smit

Каши есть немного или много)) Недавно в 1с и есть пробелы в знаниях, но я честно борюсь с этим, и есть задачки в которых дают разбираться, пытаюсь всех догнать…

Ошибка при вызове метода контекста (Записать)

ссори

   mr_smit

тУникИндификатор-это код и в пвх и в справочнике??  — поставили задачу, чтобы номера совпадали,что мы знали что мы это туда занесли. хотя сейчас сам задумался зачем, пойду ка уточню

   mr_smit

Рускиий я))))) Не эфиоп, так исторически сложилось))

   mr_smit

а получилось не Русский))) написал то, как всегда)

   mr_smit

Спасибо. с ссылкой заработало. Может не сочтёте за труд пояснить почему так? Спасибо

   h-sp

(24) ну есть же этот элемент уже, НовЭлемПВХ.Ссылка, зачем второй раз его искать?

   mr_smit

а понятно при создании документа появляется этот елемент, не понимаю как только соотносится о владелец к ссылке. Надо наверное просто запомнить что это так. Спасибо

 

Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Странные ошибки "Ошибка при вызове метода контекста"

Ошибка при вызове метода контекста ПолучитьОбъект()

Я
REDANGER Всем добрый день! Пытаюсь определить является ли ссылка пустой, если нет то ПолучитьОбъект:

Процедура ОбработкаПроведения(Отказ, РежимПроведения)      Если НЕ Ссылка.ГрафикТО.Пустая() Тогда         Граф = Ссылка.ГрафикТО.Ссылка.ПолучитьОбъект(); Для каждого Элемент Из Граф.ТехОбсл Цикл     Если Элемент.Маршрут = Ссылка.Маршрут Тогда         Элемент.ТО = Истина;         Элемент.Акт = Ссылка;         Граф.Записать();     КонецЕсли; КонецЦикла; КонецЕсли; КонецПроцедуры
Вообще задача следующая: есть документы ГрафикТО и АктТО; в ТЧ документа ГрафикТО имеются реквизиты: ТО (Булево) и Акт (ДокументСсылка.АктТО). Нужно чтобы при проведении документа АктТО, в ТЧ документа ГрафикТО, скажем так, фиксировался факт проведения Акта.

Но это не совсем получается…использовал ТочкуОстанова, начал проверять:
строка "Ссылка.ГрафикТО.Пустая()" выдает: Значение (Истина), Тип (Булево); строка Ссылка.ГрафикТО.Ссылка.ПолучитьОбъект() выдает: Значение: (см. тему поста) Скажите как быть в данной ситуации?
 
     h-sp во первых Граф = Ссылка.ГрафикТО.ПолучитьОбъект();    YFedor

(0) если битая ссылка, то она не пустая и ПолучитьОбъект тоже выдаст ошибку

   h-sp (0)        Граф.Записать(); после цикла поставь    REDANGER

(1)(3) К сожалению, ничего не изменилось

   REDANGER

(2) да не должна бы..я и с имеющимися пробовал и новые документы создавал — эффект один

   h-sp

(5) значит в модуле объекта документа  ГрафикТО какая-то хрень написана. Найдите автора этого модуля.

   AsadRoman

(0) А где процедурка-то выполняется?

   REDANGER

(7) в модуле объекта АктаТО

   h-sp

(8) ну покажите самый низ модуля объекта этого графика, там никакой туфты нет?

   REDANGER

(9) модульобъекта графикаТО вообще пустой у меня

 
     Вафель

А где сама ошибка то???

   REDANGER

вообще фактически он ошибку не выдает, но и при проведении АктаТО в ТЧ документа ГрафикТО он не заполняет соответствующие колонки, в них как было пусто так и есть

   Радим1987

Граф.ТехОбсл это таблица значений?

   Радим1987 Процедура ОбработкаПроведения(Отказ, РежимПроведения)      Если НЕ Ссылка.ГрафикТО.Пустая() Тогда         Граф = Ссылка.ГрафикТО.ПолучитьОбъект(); Для каждого Элемент Из Граф.ТехОбсл Цикл     Если Элемент.Маршрут = Ссылка.Маршрут Тогда         Элемент.ТО = Истина;         Элемент.Акт = Ссылка;             КонецЕсли; КонецЦикла; Граф.Записать(РежимЗаписиДокумента.Запись); КонецЕсли; КонецПроцедуры    h-sp

(12) чего же ты нас за нос водишь тогда?

   REDANGER (13) это табличная часть документа ГрафикТО
(14) не помогает
(15) да нет желания за нос водить, хочется разобраться в чем причина, сорри если с первого раза неверно поставил вопрос.

Ошибку он выдает в том случае если сделать так:

Если (без НЕ) Ссылка.ГрафикТО.Пустая() Тогда         Граф = Ссылка.ГрафикТО.ПолучитьОбъект(); тогда да ругается что: Ошибка при вызове метода контекста ПолучитьОбъект() и также пишет: Элемент не выбран

   Радим1987 (14) ошибочка Граф = Ссылка.ПолучитьОбъект();
Процедура ОбработкаПроведения(Отказ, РежимПроведения)      Если НЕ Ссылка.ГрафикТО.Пустая() Тогда         Граф = Ссылка.ПолучитьОбъект(); Если не Граф.ТехОбсл.Пустая() тогда Для каждого Элемент Из Граф.ТехОбсл Цикл     Если Элемент.Маршрут = Ссылка.Маршрут Тогда         Элемент.ТО = Истина;         Элемент.Акт = Ссылка;             КонецЕсли; КонецЦикла; КонецЕсли; Граф.Записать(РежимЗаписиДокумента.Запись); КонецЕсли; КонецПроцедуры    h-sp

(17) что-то вы заработались.

 

Наведи порядок в своей работе используя конфигурацию 1C "Управление IT-отделом 8"

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Ошибка при вызове метода контекста в 1С

Хочу ТЗ добавить колонки почему выдает ошибку

Я
Genri Тволна — ТЗ на форме; Для ин=1по52цикл ИмяК="К"+1; Тволна.Колонки.Добавить(ИмяК,Новый ОписаниеТипов("Число")); КонецЦикла; ПИШИТ:
{Форма.Форма(286)}: Ошибка при вызове метода контекста (Добавить): Неверное имя колонки Тволна.Колонки.Добавить(ИмяК,Новый ОписаниеТипов("Число")); по причине: Неверное имя колонки 
     ДенисЧ

Сообщить(ИмяКолонки) ?

   zbv

Одна из причин: есть уже такая колонка

   Asmody

ошибка тут ИмяК="К"+1

   Euguln Может все же ИмяК="К"+ин;    Дуб

(3) +1
(0) ты одноимённую колонку пытаешься вводить, не делая инкремента номера..

   Asmody

пора книгу писать "Миста — как средство групповой отладки"

   Genri (5)это я понял протупил делаю так
ИмяК="К"+ин;
ПИШИТ:
{Форма.Форма(286)}: Ошибка при вызове метода контекста (Добавить): Неверное имя колонки Тволна.Колонки.Добавить(ИмяК,Новый ОписаниеТипов("Число"));по причине:    Asmody

плин, ну воткни ты Сообщить(ИмяК); перед Тволна.Колонки.Добавить(); много интересного увидишь

   zbv

(6) +1

(7) добавь проверку на существующие колонки.

   Живой Ископаемый

пишИт

 
     Дуб

(9) при грамотном добавлении колонок проверять ничего не надо..

   Genri

(8)Счет идет К1,К2,К3…. но колонки на форме не добавляються.

   zbv

(11) согласен.

   Asmody

а сейчас товарищи объяснят, что "ТЗ на форме" — это небывает

   Genri

(14)В смысле небывает.

   Asmody

(15) в смысле, что на форме у тебя лежит табличное поле, к которому привязана таблица значений.

Ошибка при вызове метода контекста

а это суть разные объекты.

   dimoff

Хорошо когда на 16 дебильных постов один верный, значит не все так плохо, спасибо 4.

   Asmody

(17) для обучения есть два пути: сказать "вот так правильно" и сказать "вот так не правильно". в первом случае обучаемый получит рыбу, а во втором — удочку. разницу чуешь?

   Genri Все, всем спасибо, разобрался…
ТСтат=Новый ТаблицаЗначений; Для ин=1по52цикл ИмяК="К"+ин; ТСтат.Колонки.Добавить(ИмяК,Новый ОписаниеТипов("Число")); КонецЦикла; ЭлементыФормы.ТВолна.Значение=ТСтат; ЭлементыФормы.ТВолна.СоздатьКолонки(); Так работает    ДенисЧ

(17) На 19.

   dimoff

(18) Да, ты тоже прав.

 

Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Внимание! Ошибка при работе сервиса «1С:Контрагент»!

Обращаем ваше внимание, что у некоторых пользователей «1С:Бухгалтериий 8» редакции 3.0 может возникать ошибка при работе сервиса «1С:Контрагент»:

«При вызове веб-сервиса произошла ошибка. Неизвестная ошибка.

Ошибка при вызове метода контекста в 1С 8.2 и выше

Ошибка преобразования данных XDTO: Чтение объекта типа: {http://company1c.com/orgregister/corporation}СвОКВЭД — » (полный текст ошибки ниже).

ДЛЯ УСТРАНЕНИЯ ОШИБКИ НЕОБХОДИМО ВЫПОЛНИТЬ СЛЕДУЮЩИЕ ДЕЙСТВИЯ:

Администратор сервиса в неразделенном сеансе должен открыть список регистра сведений «Кэш программных интерфейсов» (Главное меню → Все функции → Регистры сведений → Кэш программных интерфейсов). В открывшемся списке необходимо найти и удалить запись со значением в колонке Идентификатор https://api.orgregister.1c.ru/orgregister/v7?wsdl. После этого пользователи, у которых возникала ошибка при заполнении реквизитов, должны выйти из программы и войти снова.

Вы можете обратиться за помощью на Линию Консультаций «Интерсофт» по телефону  8(861)298-06-67 или e-mail: its@inter-soft.ru.

ПОЛНЫЙ ТЕКСТ ОШИБКИ

ОбщийМодуль.ДанныеЕдиныхГосРеестров.Модуль(181)}: Ошибка при вызове метода контекста (getCorporationRequisitesByNameAndAddress) 

Ответ = Прокси.getCorporationRequisitesByNameAndAddress(ВходныеПараметры); 

по причине: 

При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса: {http://ws.orgregister.company1c.com/}…dAddress()

по причине: 

При вызове веб-сервиса произошла ошибка. Неизвестная ошибка. Ошибка преобразования данных XDTO: 

Чтение объекта типа: {http://company1c.com/orgregister/corp…on}СвОКВЭД —  

Проверка дополнительного свойства: 

форма: Атрибут 

имя: ПрВерсОКВЭД 

по причине: 

Ошибка преобразования данных XDTO: 

Чтение объекта типа: {http://company1c.com/orgregister/corp…on}СвОКВЭД —  

Проверка дополнительного свойства: 

форма: Атрибут 

имя: ПрВерсОКВЭД 

по причине: 

Ошибка проверки данных XDTO: 

Структура объекта не соответствует типу: {http://company1c.com/orgregister/corp…on}СвОКВЭД 

Для получения подробной информации обращайтесь на Линию консультаций по т. 8(861)298-06-67 

или к менеджерам компании «Интерсофт» по т. 8(861)298-06-70 или e-mail: its@inter-soft.ru

Возврат к списку

Ошибка при вызове метода контекста (Выполнить)

Я
kalisto Доброго времени суток.
Помогите пожалуйста разобраться в проблеме (конфигурация УТ 10.3 клиент-сервер).
Добавила новый регистр накопления, прописала в процедуре проведения документа Перемещения товаров запрос на выборку данных из этого регистр. Создала роль, дала права чтения, записи на этот регистр и на нужные документы, в том числе и Перемещение. Некоторое время все было хорошо, документы проводились без проблем. Недавно при проведении документа Перемещение товаров программа стала выдавать ошибку при выполнении запроса к новому регистру при проведении документа Перемещение товаров:
{Документ.ПеремещениеТоваров.МодульОбъекта(2491)}: Ошибка при вызове метода контекста (Выполнить)         РезультатЗапроса = ЗапросУценка.Выполнить().Выбрать();по причине:
Недостаточно прав для работы с таблицей "Документ.ВходящийЗапросКаталога".
Странно, что программа выдает совсем посторонний документ, который никак не затрагивается при проведении документа Перемещения и в запросе к новому регистру.

Ошибки в 1С, связанные с контекстным методом

И регистратором в новом регистре такой документ не является.
Подскажите пожалуйста, по какой причине может возникать данная ситуация.
 
 

   RomanYS

запрос покажи

   kalisto ЗапросУценка.Текст = "ВЫБРАТЬ         |    ПартииТоваровНаСкладахУценкаОстатки.Номенклатура КАК Номенклатура,         |    ПартииТоваровНаСкладахУценкаОстатки.ДокументОприходования КАК ДокументОприходования,         |    ПартииТоваровНаСкладахУценкаОстатки.КоличествоОстаток КАК КолвоОстаток,         |    ПартииТоваровНаСкладахУценкаОстатки.СтоимостьОстаток КАК Стоимость,         |    ПартииТоваровНаСкладахУценкаОстатки.ХарактеристикаНоменклатуры,         |    ПартииТоваровНаСкладахУценкаОстатки.СерияНоменклатуры,         |    ПартииТоваровНаСкладахУценкаОстатки.СтатусПартии,         |    ПартииТоваровНаСкладахУценкаОстатки.Качество,         |    ПартииТоваровНаСкладахУценкаОстатки.ОприходованиеТовара КАК ОприходованиеТовара,         |    ПартииТоваровНаСкладахУценкаОстатки.ОприходованиеТовара.Дата КАК ДатаПрихода         |ИЗ         |    РегистрНакопления.ПартииТоваровНаСкладахУценка.Остатки(&МомВремени, ) КАК ПартииТоваровНаСкладахУценкаОстатки         |ГДЕ         |    ПартииТоваровНаСкладахУценкаОстатки.Склад = &СкладРеализации         |    И ПартииТоваровНаСкладахУценкаОстатки.Номенклатура В ИЕРАРХИИ(&СписокНоменклатуры)         |    И ПартииТоваровНаСкладахУценкаОстатки.ДокументОприходования В ИЕРАРХИИ(&СписокПартий)         |         |СГРУППИРОВАТЬ ПО         |    ПартииТоваровНаСкладахУценкаОстатки.Номенклатура,         |    ПартииТоваровНаСкладахУценкаОстатки.ДокументОприходования,         |    ПартииТоваровНаСкладахУценкаОстатки.ОприходованиеТовара,         |    ПартииТоваровНаСкладахУценкаОстатки.ХарактеристикаНоменклатуры,         |    ПартииТоваровНаСкладахУценкаОстатки.СерияНоменклатуры,         |    ПартииТоваровНаСкладахУценкаОстатки.СтатусПартии,         |    ПартииТоваровНаСкладахУценкаОстатки.Качество         |         |УПОРЯДОЧИТЬ ПО         |    Номенклатура,         |    ДокументОприходования,         |    ДатаПрихода";    RomanYS скорей всего проблема здесьПартииТоваровНаСкладахУценкаОстатки.ОприходованиеТовара.Дата

проверяй тип ОприходованиеТовара    Bober

(0) если платформа 8.2, то перед выполнение запроса поставь
УстановитьПривилегированныйРежим(Истина)

(2) отборы нужно перенести в параметры вирт таблицы остатки

   kalisto

Спасибо за ответы.
Буду пробовать.

   User_Agronom (0) На копии отладчик под тем пользователем, под которым падает многое может рассказать.

Но если лень и нужно быстро: в (2) попробуй  "ЗапросУценка.Текст = "ВЫБРАТЬ разрещшенные …"
(4) Не взлетит. Выполняется только на сервере. На клиенте ошибку не выдаёт, но привилегированный режим не устанавливает.    Bober

(6) почему, толстый клиент тоже.

   User_Agronom

(7) Пробовал?

 

Наведи порядок в своей работе используя конфигурацию 1C "Управление IT-отделом 8"

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.